New Device Query Inaccuracy

Incident Report for Kentik SaaS US Cluster

Resolved

This issue is now resolved.
Posted Jan 30, 2026 - 01:37 UTC

Identified

The issue has been identified and we are deploying a fix.
Posted Jan 29, 2026 - 23:59 UTC

Investigating

Customers may observe missing or inaccurate data for devices added or modified within the last ~48 hours. We are actively investigating.
Posted Jan 29, 2026 - 23:26 UTC
This incident affected: Query.