High latency in NMS Alert evaluation

Incident Report for Kentik SaaS US Cluster

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 23, 2026 - 20:15 UTC

Monitoring

At 18:20 UTC a host running an internal API service began to experience issues, resulting in high alert evaluation latency for NMS Alerts. Our team was able to quickly reallocate resources and restore service. Queues began shrinking at 18:50 and were back to normal levels around 19:00 UTC. This caused delays in notifications for NMS customers and possibly some confusing notifications as the backlog was processed. The issue has been resolved.
Posted Sep 23, 2026 - 20:14 UTC