Degraded Portal and API Performance

Incident Report for Kentik SaaS US Cluster

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 17:05 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 17, 2026 - 23:12 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2026 - 23:12 UTC

Investigating

We are currently investigating reports of degraded performance across the Portal and API. Customers may experience slow page loads or intermittent API latency. Our team is actively triaging the issue, and we will provide another update as soon as we know more.
Posted Jun 17, 2026 - 22:54 UTC
This incident affected: Web Portal and REST API.