Flow Enrichment Degradation

Incident Report for Kentik SaaS US Cluster

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 11:52 UTC

Monitoring

Enrichment services have been fully restored and are operating as expected. Continuous monitoring is in place to confirm stability and prevent recurrence.
Posted Jun 17, 2026 - 09:08 UTC

Investigating

We are currently investigating this issue.
Posted Jun 17, 2026 - 07:52 UTC
This incident affected: Flow Ingest.