Degraded KDE Query Performance in Portal
Incident Report for Kentik SaaS US Cluster
Postmortem

ROOT CAUSE

This incident was caused by a software bug in query cancellation that caused our query engine to become unresponsive. 

RESOLUTION

Internal alerting notified our teams of this issue and we immediately rolled out a fix later in the day.

Posted Oct 07, 2022 - 17:51 UTC

Resolved
This incident has been resolved.
Posted Jul 08, 2022 - 18:52 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 08, 2022 - 16:00 UTC
Monitoring
A fix has been implemented and we are closely monitoring system health.
Posted Jul 08, 2022 - 15:46 UTC
Identified
A subset of Kentik Portal sessions are experiencing failed KDE queries with 5xx errors.
Posted Jul 08, 2022 - 15:44 UTC
This incident affected: Web Portal.